Кошка-зима. Умная, смелая и вежливая (zuiki) wrote,
Кошка-зима. Умная, смелая и вежливая
zuiki

  • Mood:

Программирование: Тяжкое наследие

Фрагмент (на условном сферическом языке программирования для вакуума):
Аванс = СуммаАванса();
~Аванс: //метка
Если Аванс>0 Тогда
  Док.ВыбратьДокументы();
  Пока Док.ПолучитьДокумент()=1 Цикл
    Ответ = Вопрос("Некий вопрос","Да+Нет");
    Если Ответ="Нет" Тогда
      Аванс = 0;
      Перейти ~Аванс;
    КонецЕсли;
  КонецЦикла;
КонецЕсли;

Я так понимаю, красное условие -- это такой аналог инструкции Прервать (которая в данном сферическом языке реализована, кстати)? Я вот просто никак не вспомню -- ведь в классическом goto-программировании не по Дейкстре метки вроде видны на всем пространстве программного модуля с ограничениями на переход внутрь циклических и условных конструкций. То есть из цикла-то можно выйти не только вверх, но и вниз? Или нет?
Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your IP address will be recorded 

  • 2 comments